Configuration not saving?

May 3, 2010 at 6:56 PM

Hello

I have installed the IWCF module. The module keeps telling me "You must set the URL for the WCF service below" even after I do so. I restart DNN application or even IIS.

I have several portals installed and have tried the module on more than one... same behavior.

The module lists all the methods correctly. The database tables DNN_IWebCFMethods and DNN_IWebCFSettings have been created, but DNN_IWebCFSettings is always EMPTY.

 

Please advise.

Regards

Paolo

Coordinator
May 3, 2010 at 8:08 PM

What version of DotNetNuke are you using? Also, what version of ASP.NET are you using and what operating system?

May 3, 2010 at 8:14 PM

Thanks for you reply...

Windows 7, asp.net 3.5 on DNN pro 5.02.02

 

Coordinator
May 3, 2010 at 9:30 PM

It may take a few days for me to try to reproduce this. I will try to work on it soon.

Coordinator
May 6, 2010 at 3:30 AM

Ok I just tested it with:

Windows 7, asp.net 3.5 on DNN pro 5.03.01

It works. The URL is set in the IWebCFConfiguration table, not the IWebCFSettings table.

Can you try it again with the latest DNN and only one portal? The problem may be with multiple portals.

Jul 12, 2010 at 8:49 PM
What's the proper procedure to install this IWebCF module? I don't get the prompt for "You must set the URL for the WCF service below" at all and this could be the reason why I'm not able to access it at all.
Coordinator
Jul 12, 2010 at 9:50 PM
If you already have an entry in the IWebCFConfiguration you will not get the "You must set the URL for the WCF service below" message.
Jul 12, 2010 at 10:55 PM

After I install the module, there's nothing in the table IWebCFConfiguration.  When I try to add the module to a page so I can configure it, it errors out with a message "IWebCF is currently unavailable.
DotNetNuke.Services.Exceptions.ModuleLoadException: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS...."  I can't move on getting this tested anymore.  So I tried downloading the IWeb instead and this module install works.  I'm able to add IWeb module onto a page so I can configure/use it.  I don't know what value to configure for "Encryption Key" though.  Doesn't it have to match an existing key that's being used in my DNN site?  if so, where can I locate it?  It's restricted to a 5 character on the configuration page???

Coordinator
Jul 12, 2010 at 11:14 PM

IWebCF uses Windows Communication Foundation (WCF) so it is a "different beast". IWeb uses .asmx web services, so if it's working for you then use that.

Yes you are limited to a 5 character encryption key. It's used to encrypt data transmitted. You really don't need it, it's just there for people if they want it.

Jul 12, 2010 at 11:58 PM

ah didnt realize you didnt need it.  thanks.  I think I still like using it myself.  if you do set that key, your requesting program will need to provide it in order to authenticate.

Jul 13, 2010 at 3:38 PM
Edited Jul 13, 2010 at 4:03 PM

Please show me how to pass an encrypted password in IWebAuthendicationHeader object as well as the encrypted password to the IWeb call for CreateUser. The first is for validating/authorizing current username to see if that person has access to IWeb and the second is the one we'd like to create a user for. Thanks.

 

Jul 13, 2010 at 3:52 PM

I am just a novice with this but I set up a Password property in my app and encrypt the value before storing it then I pass the property to the header class:

public string Password
{
    get
    {
 return this._textPassword;
    }

    set
    {
        string password = String.Empty;
        IWebEncryption objIWebEncryption = new IWebEncryption();
        password = objIWebEncryption.Encryption(value.Trim(), "blues");
        password = HttpUtility.UrlEncode(password);
        this._textPassword = password;
     }
}